dda-backup/infrastructure/backup/image/resources2/check.bb

23 lines
No EOL
622 B
Clojure
Executable file

#!/usr/bin/env bb
(require '[dda.backup.restic :as rc])
(def restic-repo {:password-file "/restic-pwd"
:restic-repository "/restic-repo"
:debug true})
(def file-config (merge restic-repo {:backup-path "files"
:files ["/test-backup"]
:restore-target-directory "/test-restore"}))
(def cred-config (merge file-config {:new-password-file "new-pw"}))
(def dry-run {:dry-run true :debug true})
(defn restic-repo-check
[]
(println "restic-repo-check")
(println (rc/check file-config)))
(restic-repo-check)